LOGIN.

管理员登陆入口 ^_^!

您好,欢迎访问网站!
  [查看权限]

欢迎加入QQ群!

595998749
2015年05月24日 23:34:51

今遇到的问题ROS动态IP端口映射(转至大城小我)

首先添加脚本,可直接在终端复制运行,也可按脚本进行图文添加

/ip firewall nat add chain=dstnat dst-address=58.58.58.58 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.254 to-ports=80 comment="80"

部分解释:
dst-address=58.58.58.58 #这个你可以不用管他了..就用这个..会自动刷新更换,
protocol=tcp #这个tcp为你映射端口所使用的协议..常见的有udp
dst-port=80 #这里设置外网端口(外网端口可以设置和内网不一样)
to-addresses=192.168.0.254 #这里设置你需要映射的内网IP地址
to-ports=80 #这里设置你内网服务器需要映射的端口(建议大家不要用80,因为ADSL和拨号光纤的80端口是不开放的,)
comment="80" #这里是一个关键,这里的80可以随便设置,但一定要和下面脚本中的comment一致.否则映射失败!建议使用外网端口!

然后 添加刷新IP脚本(说白了把动态IP转成固定IP,这样大伙容易理解一点) 由于动态IP随时都可能改变,那么我们需要设置他运行的时间周期.这时我们需要用到ROS的计划任务功能(Scheduler)

打开winbox --- system --- Scheduler里面设置

脚本如下:

:global newipaddress
:global lodipaddress
:set newipaddress [/ip address get [/ip address find dynamic=yes interface="pppoe-out1"] address]
:set newipaddress [:pick $newipaddress 0 ([:len $newipaddress] -3)]
:set lodipaddress [/ip firewall nat get [/ip firewall nat find comment="80"] dst-address]
:if ($newipaddress != $lodipaddress) do={/ip firewall nat set [/ip firewall nat find comment="80"] dst-address=$newipaddress}

部分解释:
interface="pppoe-out1" #这里设置你PPPOE拔号的名称,注意大小写
comment="80" #这里就是我们刚才说的关键了(上面蓝色部分).两处都一样.你上面设置什么.这里就一定要设置什么.否则此脚本失效!

« 上一篇 下一篇 »

发表评论:

名称(*)
邮箱
网址
验证码(*)
正文(*)
◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。