LOGIN.

管理员登陆入口 ^_^!

您好,欢迎访问网站!
  [查看权限]

欢迎加入QQ群!

595998749
2016年07月02日 23:00:46

光纤(VPN)走上行 ADSL走下行

本实例是3线AD

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
现在所有上传流量都跑第二条AD

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
这里的设置相对是PCC负载和地址转换

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
这里的IP地址为公网的IP地址

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ

 

光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
这里设置上传跑那条线路出去,也设置为上传2线负载
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
上面是个跳转设置
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
这里是设置链接标记,标记名称无所谓,看个人习惯
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
这里是设置标记路由,也是设置上传走那么线路
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
设置路由表,还要装载标记路由
 
光纤(VPN)走上行 ADSL走下行 - Dream of - メ雨後的兲倥ミ
 
设置动态IP更新脚本
 
 
 
/ip firewall nat
add action=src-nat chain=srcnat comment=ADSL1 disabled=no \
    per-connection-classifier=both-addresses-and-ports:3/0 src-address=\
    192.168.110.0/24 to-addresses=183.31.10.159
add action=src-nat chain=srcnat comment=ADSL2 disabled=no \
    per-connection-classifier=both-addresses-and-ports:3/1 src-address=\
    192.168.110.0/24 to-addresses=183.31.10.158
add action=src-nat chain=srcnat comment=ADSL3 disabled=no \
    per-connection-classifier=both-addresses-and-ports:3/2 src-address=\
    192.168.110.0/24 to-addresses=183.31.10.124
 
 /ip firewall mangle
add action=change-mss chain=forward comment="---------  \B4\FA\BA\C5\A3\A8\D0\
    \C5\C4\EE2011\A3\A9\D0\C5\C4\EE\B4\B4\D4\EC\CE\DE\CF\DE | \BB\B6\D3\AD\BC\
    \D3\C8\EBQQ\C8\BA\A3\BA175671513  -----------------" disabled=no new-mss=\
    1440 protocol=tcp tcp-flags=syn
add action=jump chain=prerouting comment="" disabled=no jump-target=bonding
add action=mark-connection chain=bonding comment="" disabled=no \
    new-connection-mark=1 passthrough=yes per-connection-classifier=\
    both-addresses:3/0 src-address=192.168.110.0/24
add action=mark-routing chain=bonding comment="" connection-mark=1 disabled=\
    no new-routing-mark=2 passthrough=yes src-address=192.168.110.0/24
add action=mark-connection chain=bonding comment="" disabled=no \
    new-connection-mark=2 passthrough=yes per-connection-classifier=\
    both-addresses:3/1 src-address=192.168.110.0/24
add action=mark-routing chain=bonding comment="" disabled=no \
    new-routing-mark=2 passthrough=yes src-address=192.168.110.0/24
add action=mark-connection chain=bonding comment="" disabled=no \
    new-connection-mark=3 passthrough=yes per-connection-classifier=\
    both-addresses:3/2 src-address=192.168.110.0/24
add action=mark-routing chain=bonding comment="" connection-mark=3 disabled=\
    no new-routing-mark=2 passthrough=yes src-address=192.168.110.0/24
----------------------------------------------------------------------------------------------------------------------------------
:local curaddress
:local newaddress
:local status
:local x
:set x 3
:for i from=1 to=$x do={
    :set status [/interface get [/interface find  name=("pppoe-out" . $i)] running]
    :if ($status=true) do={
    :set newaddress [/ip address get [/ip address find dynamic=yes interface=("pppoe-out" . $i)] address ]
    :set newaddress [:pick $newaddress 0 [:find $newaddress "/"]]
    :set curaddress [ /ip firewall nat get [/ip firewall nat find comment=("ADSL" . $i)] to-addresses ]
    :if ($curaddress != $newaddress) do={
       /ip firewall nat set [ /ip firewall nat find comment=("ADSL" . $i) ] to-addresses=$newaddress
       :log info ("Change ADSL" . $i . " NAT IP" )
         }
     }
}
 
 
自动修改 NAT ip脚本 注意 comment=ADSL1  这样的格式。
不是所有运营商都会不检测源地址是否合法,


« 上一篇 下一篇 »

发表评论:

名称(*)
邮箱
网址
验证码(*)
正文(*)
◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。

评论列表:

旅游包车

评论于2016-12-30 23:58:50
好专业的。有点看不太懂。 - 回复该评论

大城小我

评论于2016-07-12 20:16:13
有图有真相,不错呀 - 回复该评论

旅游包车

评论于2016-12-30 23:58:50
好专业的。有点看不太懂。 - 回复该评论

大城小我

评论于2016-07-12 20:16:13
有图有真相,不错呀 - 回复该评论

旅游包车

评论于2016-12-30 23:58:50
好专业的。有点看不太懂。 - 回复该评论

大城小我

评论于2016-07-12 20:16:13
有图有真相,不错呀

wxhu

评论于2016-07-12 22:45:07
你网站做得不错哦,发展挺快的。 - 回复该评论

wxhu

评论于2016-07-12 22:45:07
你网站做得不错哦,发展挺快的。 - 回复该评论

wxhu

评论于2016-07-12 22:45:07
你网站做得不错哦,发展挺快的。 - 回复该评论
- 回复该评论